LightGroup Class

LightGroup Class

This class represents a set of lights grouped together for easier management of various lighting scenarios
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.LightingLightGroup

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LightGroup : IDisposable
Public Class LightGroup
	Implements IDisposable
public ref class LightGroup : IDisposable
type LightGroup = 
    class
        interface IDisposable
    end

The LightGroup type exposes the following members.

Properties
 NameDescription
Public propertyId The ElementId of the LightGroup
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName The name of the LightGroup
Top
Methods
 NameDescription
Public methodAddLight Add a new light instance to the group
Public methodDisposeReleases all resources used by the LightGroup
Public methodGetLights Get the set of contained light instances The set of light instances
Public methodRemoveLight Remove the given light instance from the set of light instances in this group
Top
See Also