ServiceType Enumeration

ServiceType Enumeration

This enumeration is used for specifying the most predominant service for the building or space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ServiceType
Public Enumeration ServiceType
public enum class ServiceType
type ServiceType
Members
Member nameValueDescription
kActiveChilledBeams22Service Type is ActiveChilledBeams.
kCentralHeatingConvectors1Service Type is CentralHeatingConvectors.
kCentralHeatingHotAir3Service Type is CentralHeatingHotAir.
kCentralHeatingRadiantFloor2Service Type is CentralHeatingRadiantFloor.
kCentralHeatingRadiators0Service Type is CentralHeatingRadiators.
kConstantVolumeDualDuct20Service Type is ConstantVolumeDualDuct.
kConstantVolumeFixedOA16Service Type is ConstantVolumeFixedOA.
kConstantVolumeTerminalReheat18Service Type is ConstantVolumeTerminalReheat.
kConstantVolumeVariableOA17Service Type is ConstantVolumeVariableOA.
kFanCoilSystem14Service Type is FanCoilSystem.
kForcedConvectionHeaterFlue8Service Type is ForcedConvectionHeaterFlue.
kForcedConvectionHeaterNoFlue9Service Type is ForcedConvectionHeaterNoFlue.
kInductionSystem15Service Type is InductionSystem.
kMultizoneHotDeckColdDeck19Service Type is MultizoneHotDeckColdDeck.
kNoServiceType-1Service Type is NoServiceType.
kOtherRoomHeater4Service Type is OtherRoomHeater.
kRadiantCooledCeilings21Service Type is RadiantCooledCeilings.
kRadiantHeaterFlue5Service Type is RadiantHeaterFlue.
kRadiantHeaterMultiburner7Service Type is RadiantHeaterMultiburner.
kRadiantHeaterNoFlue6Service Type is RadiantHeaterNoFlue.
kSplitSystemsWithMechanicalVentilation26Service Type is SplitSystemsWithMechanicalVentilation.
kSplitSystemsWithMechanicalVentilationWithCooling27Service Type is SplitSystemsWithMechanicalVentilationWithCooling.
kSplitSystemsWithNaturalVentilation25Service Type is SplitSystemsWithNaturalVentilation.
kVariableRefrigerantFlow24Service Type is VariableRefrigerantFlow.
kVAVDualDuct11Service Type is VAVDualDuct.
kVAVIndoorPackagedCabinet12Service Type is VAVIndoorPackagedCabinet.
kVAVSingleDuct10Service Type is VAVSingleDuct.
kVAVTerminalReheat13Service Type is VAVTerminalReheat.
kWaterLoopHeatPump23Service Type is WaterLoopHeatPump.
Remarks
This enumerated list corresponds to the serviceType attribute in the gbXML (Green Building XML) schema and is primarily used for energy analysis.
See Also