Element.IsExternalFileReference Method

ElementIsExternalFileReference Method

Determines whether this Element represents an external file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsExternalFileReference()
Public Function IsExternalFileReference As Boolean
public:
bool IsExternalFileReference()
member IsExternalFileReference : unit -> bool 

Return Value

Boolean
True if this element contains information about some external file, false if it does not.
Remarks
Linked files are references to external files, but imported files are not, as their data is brought wholly into Revit.
See Also