Element.CanHaveTypeAssigned Method

ElementCanHaveTypeAssigned Method

Identifies if the element can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool CanHaveTypeAssigned()
Public Function CanHaveTypeAssigned As Boolean
public:
bool CanHaveTypeAssigned()
member CanHaveTypeAssigned : unit -> bool 

Return Value

Boolean
True if element can have a type assigned, false otherwise.
Remarks
Some elements cannot have type assigned, in which case invalid element id is considered to be their type id.
See Also