Revit 2026 API
ElementGet |
Returns the ids of the element(s) that generated the input geometry object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ICollection<ElementId> GetGeneratingElementIds( GeometryObject geometryObject )
Public Function GetGeneratingElementIds ( geometryObject As GeometryObject ) As ICollection(Of ElementId)
public: ICollection<ElementId^>^ GetGeneratingElementIds( GeometryObject^ geometryObject )
member GetGeneratingElementIds : geometryObject : GeometryObject -> ICollection<ElementId>
Parameters
- geometryObject GeometryObject
- The geometry object whose generating element is requested.
Return Value
ICollectionElementIdThe id(s) of the element(s) that generated (or may have generated) the given geometry object. Empty if no generating elements are found. If the set contains just one id, it is the id of the element that generated the geometry object.

Exception | Condition |
---|---|
ArgumentException | The input geometryObject is invalid and so cannot be used to obtain the generating element ids. |
ArgumentNullException | A non-optional argument was null |

This function supports many different types of relationships among elements.
Most of these relationships will return a single element, for example:
- Window and door cutting walls
- Openings cutting hosts
- Face splitting faces
- Wall sweep or reveal traversing wall
- Walls joining to other wall(s)
- Elements extending to roof(s)
See Also