ElementOwnerViewFilter(ElementId) Constructor

ElementOwnerViewFilter(ElementId) Constructor

Constructs a new instance of a filter to match elements which are owned by a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementOwnerViewFilter(
	ElementId viewId
)
Public Sub New ( 
	viewId As ElementId
)
public:
ElementOwnerViewFilter(
	ElementId^ viewId
)
new : 
        viewId : ElementId -> ElementOwnerViewFilter

Parameters

viewId  ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also