StairsRunStyle Enumeration

StairsRunStyle Enumeration

The shape of a run. Different shape has different ways of manipulation.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public enum StairsRunStyle
Public Enumeration StairsRunStyle
public enum class StairsRunStyle
type StairsRunStyle
Members
Member nameValueDescription
Sketched2 A sketched run can have customized boundary and riser curves. User can customize stair path as well.
Spiral4 A spiral run is defined by a cylindrical helix. Both inner and outer boundaries are arcs. Risers are straight lines.
Straight3 A straight run is defined by a straight line. All treads are rectangular.
Winder1 A winder run has distorted treads, for the sake of space saving at corner.
See Also