Revit 2026 API
Baluster |
A class which contains information regarding baluster and post placement for a given railing type.

SystemObject
Autodesk.Revit.DB.ArchitectureBalusterPlacement
Autodesk.Revit.DB.ArchitectureBalusterPlacement
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
The BalusterPlacement type exposes the following members.

Name | Description | |
---|---|---|
![]() | BalusterPattern | Accesses the object containing properties related to the baluster pattern. |
![]() | BalusterPerTreadFamilyId | The id of baluster per tread family. |
![]() | BalusterPerTreadNumber | The number of balusters per tread. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | PostPattern | Accesses the object containing properties related to the post pattern. |
![]() | UseBalusterPerTreadOnStairs | If true, one or more balusters will be included on each tread of an associated stair. If false, this is not guaranteed to happen. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the BalusterPlacement |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
See Also