GeometryObject.GraphicsStyleId Property

GeometryObjectGraphicsStyleId Property

The ElementId of the GeometryObject's GraphicsStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId GraphicsStyleId { get; }
Public ReadOnly Property GraphicsStyleId As ElementId
	Get
public:
property ElementId^ GraphicsStyleId {
	ElementId^ get ();
}
member GraphicsStyleId : ElementId with get

Property Value

ElementId
Remarks
This property provides the id of the GraphicsStyle assigned to the GeometryObject. This can be used to find the category of the object.
See Also