Revit 2026 API
ElementIs |
Returns true if createdPhaseId and demolishedPhaseId are in order.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool IsDemolishedPhaseOrderValid( ElementId demolishedPhaseId )
Public Function IsDemolishedPhaseOrderValid ( demolishedPhaseId As ElementId ) As Boolean
public: bool IsDemolishedPhaseOrderValid( ElementId^ demolishedPhaseId )
member IsDemolishedPhaseOrderValid : demolishedPhaseId : ElementId -> bool
Parameters
- demolishedPhaseId ElementId
- The demolishedPhaseId.
Return Value
BooleanTrue if createdPhaseId index is less than or equal to demolishedPhaseId, otherwise returns false.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also