Revit 2026 API
Multistory |
Checks if the given level can be disconnected from multistory stairs.
You cannot disconnect the levels of standard stair (the stair associated with the Reference Level for the multistory stairs) or already disconnected.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool CanDisconnectLevel( ElementId levelId )
Public Function CanDisconnectLevel ( levelId As ElementId ) As Boolean
public: bool CanDisconnectLevel( ElementId^ levelId )
member CanDisconnectLevel : levelId : ElementId -> bool
Parameters
- levelId ElementId
- The id of the level.
Return Value
BooleanTrue if the level id can be used to remove stairs.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also