Element.DesignOption Property

ElementDesignOption Property

Returns the design option to which the element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public DesignOption DesignOption { get; }
Public ReadOnly Property DesignOption As DesignOption
	Get
public:
property DesignOption^ DesignOption {
	DesignOption^ get ();
}
member DesignOption : DesignOption with get

Property Value

DesignOption
Remarks
If the element is not in a design option, i.e. in the main model, then this property will return .
See Also