ElementClassFilter(Type) Constructor

ElementClassFilter(Type) Constructor

Constructs a new instance of a filter to match elements by class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementClassFilter(
	Type type
)
Public Sub New ( 
	type As Type
)
public:
ElementClassFilter(
	Type^ type
)
new : 
        type : Type -> ElementClassFilter

Parameters

type  Type
The type to match.
Exceptions
ExceptionCondition
ArgumentException The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
ArgumentNullException A non-optional argument was null
See Also