MassSurfaceData.ReferenceElementId Property

MassSurfaceDataReferenceElementId Property

The ElementId of the element whose face the MassSurfaceData primarily refers to.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId ReferenceElementId { get; }
Public ReadOnly Property ReferenceElementId As ElementId
	Get
public:
property ElementId^ ReferenceElementId {
	ElementId^ get ();
}
member ReferenceElementId : ElementId with get

Property Value

ElementId
Remarks
A MassSurfaceData may represent multiple faces from the same or different elements. This generally only happens if the faces are geometrically fully coincident and logically represent a single building object. "Interior walls" of the conceptual energy building model is a common example where two different faces may be represented by a single MassSurfaceData.
See Also