Element.Parameters Property

ElementParameters Property

Retrieves a set containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ParameterSet Parameters { get; }
Public ReadOnly Property Parameters As ParameterSet
	Get
public:
property ParameterSet^ Parameters {
	ParameterSet^ get ();
}
member Parameters : ParameterSet with get

Property Value

ParameterSet
Remarks
The Parameters property contains a set of all the parameters that the element supports. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this set.
See Also