Revit 2026 API
Mechanical |
Connects a pair of placeholders that can intersect in a Tee connection.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static bool ConnectDuctPlaceholdersAtTee( Document document, ElementId placeholder1Id, ElementId placeholder2Id )
Public Shared Function ConnectDuctPlaceholdersAtTee ( document As Document, placeholder1Id As ElementId, placeholder2Id As ElementId ) As Boolean
public: static bool ConnectDuctPlaceholdersAtTee( Document^ document, ElementId^ placeholder1Id, ElementId^ placeholder2Id )
static member ConnectDuctPlaceholdersAtTee : document : Document * placeholder1Id : ElementId * placeholder2Id : ElementId -> bool
Parameters
- document Document
- The document.
- placeholder1Id ElementId
- The element Id of the first duct placeholder.
- placeholder2Id ElementId
- The element Id of the second duct placeholder.
Return Value
BooleanTrue if connection succeeds, false otherwise.

Exception | Condition |
---|---|
ArgumentException | The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa. |
ArgumentNullException | A non-optional argument was null |

The placeholders must have a physical intersection.
If connection fails, the placeholders cannot be physically connected.
See Also