ElementWorksetFilter Class

ElementWorksetFilter Class

A filter used to match elements which reside in a given workset.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementQuickFilter
      Autodesk.Revit.DBElementWorksetFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class ElementWorksetFilter : ElementQuickFilter
Public Class ElementWorksetFilter
	Inherits ElementQuickFilter
public ref class ElementWorksetFilter : public ElementQuickFilter
type ElementWorksetFilter = 
    class
        inherit ElementQuickFilter
    end

The ElementWorksetFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementWorksetFilter(WorksetId) Constructs a new instance of a filter to match elements in a given workset.
Public methodElementWorksetFilter(WorksetId, Boolean) Constructs a new instance of a filter to match elements in a given workset.
Top
Properties
 NameDescription
Public propertyWorksetId The workset id.
Top
Methods
 NameDescription
Top
Remarks
This filter is a quick filter.
See Also