ElementWorksetFilter Class

ElementWorksetFilter Class

A filter used to match elements which reside in a given workset.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementQuickFilter
      Autodesk.Revit.DBElementWorksetFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class ElementWorksetFilter : ElementQuickFilter
Public Class ElementWorksetFilter
	Inherits ElementQuickFilter
public ref class ElementWorksetFilter : public ElementQuickFilter
type ElementWorksetFilter = 
    class
        inherit ElementQuickFilter
    end

The ElementWorksetFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementWorksetFilter(WorksetId) Constructs a new instance of a filter to match elements in a given workset.
Public methodElementWorksetFilter(WorksetId, Boolean) Constructs a new instance of a filter to match elements in a given workset.
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Public propertyWorksetId The workset id.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter is a quick filter.
See Also