MassSurfaceData.GetFaceReferences Method

MassSurfaceDataGetFaceReferences Method

Gets References to the faces that the MassSurfaceData provides properties for.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IList<Reference> GetFaceReferences()
Public Function GetFaceReferences As IList(Of Reference)
public:
IList<Reference^>^ GetFaceReferences()
member GetFaceReferences : unit -> IList<Reference> 

Return Value

IListReference
Returns an array of References to Faces that the MassSurfaceData provides properties for.
Remarks
The results are always references to Faces. The Reference Type should be REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE.
See Also