AnalysisDisplayMarkersAndTextSettings Class

AnalysisDisplayMarkersAndTextSettings Class

Contains markers and text settings for analysis display style element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.AnalysisAnalysisDisplayMarkersAndTextSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class AnalysisDisplayMarkersAndTextSettings : IDisposable
Public Class AnalysisDisplayMarkersAndTextSettings
	Implements IDisposable
public ref class AnalysisDisplayMarkersAndTextSettings : IDisposable
type AnalysisDisplayMarkersAndTextSettings = 
    class
        interface IDisposable
    end

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Constructors
 NameDescription
Public methodAnalysisDisplayMarkersAndTextSettings Constructs a default instance of markers and text settings.
Public methodAnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) Constructs a new copy of the input AnalysisDisplayMarkersAndTextSettings object.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMarkerSize Size of marker.
Public propertyMarkerType Type of marker.
Public propertyRounding Increment to which numeric values of analysis results are rounded in markers.
Public propertyTextLabelType Type of diagram text label visualization.
Public propertyTextTypeId Element id of text associated with the settings.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the AnalysisDisplayMarkersAndTextSettings
Public methodIsEqual Compares two colored surface settings objects.
Top
See Also