MassSurfaceData.ConceptualConstructionId Property

MassSurfaceDataConceptualConstructionId Property

The id of the conceptual construction associated with the reference surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId ConceptualConstructionId { get; set; }
Public Property ConceptualConstructionId As ElementId
	Get
	Set
public:
property ElementId^ ConceptualConstructionId {
	ElementId^ get ();
	void set (ElementId^ value);
}
member ConceptualConstructionId : ElementId with get, set

Property Value

ElementId
Exceptions
ExceptionCondition
ArgumentException When setting this property: The input element conceptualConstructionId is not a valid ConceptualConstructionType element id.
ArgumentNullException When setting this property: A non-optional argument was null
See Also