MEPHiddenLineSettings.GetMEPHiddenLineSettings Method

MEPHiddenLineSettingsGetMEPHiddenLineSettings Method

Gets the MEP hidden line settings in the document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static MEPHiddenLineSettings GetMEPHiddenLineSettings(
	Document doc
)
Public Shared Function GetMEPHiddenLineSettings ( 
	doc As Document
) As MEPHiddenLineSettings
public:
static MEPHiddenLineSettings^ GetMEPHiddenLineSettings(
	Document^ doc
)
static member GetMEPHiddenLineSettings : 
        doc : Document -> MEPHiddenLineSettings 

Parameters

doc  Document
The document where the settings element is found.

Return Value

MEPHiddenLineSettings
The element which stores the MEP hidden line settings for the document.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also