Curve.Reference Property

CurveReference Property

Returns a stable reference to the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public Reference Reference { get; }
Public ReadOnly Property Reference As Reference
	Get
public:
property Reference^ Reference {
	Reference^ get ();
}
member Reference : Reference with get

Property Value

Reference
This value is set for curve geometry obtained from Revit elements. if the curve was created via parameters, copying, transform, or other operations.
Remarks
This value is also if the corresponding geometry object does not permit referencing.
See Also