Reference.ParseFromStableRepresentation Method

ReferenceParseFromStableRepresentation Method

Converts a stable String representation of a reference to a Reference object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static Reference ParseFromStableRepresentation(
	Document document,
	string representation
)
Public Shared Function ParseFromStableRepresentation ( 
	document As Document,
	representation As String
) As Reference
public:
static Reference^ ParseFromStableRepresentation(
	Document^ document, 
	String^ representation
)
static member ParseFromStableRepresentation : 
        document : Document * 
        representation : string -> Reference 

Parameters

document  Document
The document.
representation  String
The reference representation.

Return Value

Reference
Exceptions
ExceptionCondition
ArgumentNullExceptionOne or more arguments was .
ArgumentExceptionReference representation could not be successfully parsed, or element id obtained from reference representation could not be found in this document.
Remarks
Use ConvertToStableRepresentation(Document) to obtain the representation. The Reference will have only the following information set: You will also be able to pass the reference to Document.GetElement(reference) and Element.GetGeometryObjectFromReference(reference) to obtain the element and geometry object referred to.
See Also