Revit 2026 API
ElementDelete |
Removes a subelement from the element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool DeleteSubelement( Subelement subelem )
Public Function DeleteSubelement ( subelem As Subelement ) As Boolean
public: bool DeleteSubelement( Subelement^ subelem )
member DeleteSubelement : subelem : Subelement -> bool
Parameters
- subelem Subelement
- The subelement to delete.
Return Value
BooleanTrue if entire element was deleted, false otherwise.

Exception | Condition |
---|---|
ArgumentException | The subelement subelem does not exist in the element. -or- Subelement subelem cannot be deleted. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | This Element is an internal element, such as a component of a loaded family or a group type. -or- The document containing this Element is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This Element is a member of a group or sketch, and the document is not currently editing the group or sketch. |

Depending on implementation for given element as the result, the element
can be deleted - especially if after subelement deletion there are no subelements left.
See also: IsModifiable.
See Also