MEPAnalyticalSegmentType Enumeration

MEPAnalyticalSegmentType Enumeration

The type of analytical segment.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public enum MEPAnalyticalSegmentType
Public Enumeration MEPAnalyticalSegmentType
public enum class MEPAnalyticalSegmentType
type MEPAnalyticalSegmentType
Members
Member nameValueDescription
Fitting2 The segment is fitting.
Loss4 The terminal loss (e.g., radiator, coil, etc.)
Pump3 The segment is pump.
Segment1 The segment is straight.
SourceEquipment5 The source equipment (e.g., chiller, boiler, etc.)
Undefined0 The segment is undefined.
See Also