Revit 2026 API
ElementDelete |
Deletes the existing entity created by %schema% in the element
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool DeleteEntity( Schema schema )
Public Function DeleteEntity ( schema As Schema ) As Boolean
public: bool DeleteEntity( Schema^ schema )
member DeleteEntity : schema : Schema -> bool
Parameters
- schema Schema
- Schema used for creation of the entity
Return Value
BooleanTrue if entity was deleted, false if entity didn't exist

Exception | Condition |
---|---|
ArgumentException | Writing of Entities of this Schema is not allowed to the current add-in. |
ArgumentNullException | A non-optional argument was null |
See Also