Curve.IsArc Method (Double)

CurveIsArc Method (Double)

Test a curve to see if it can be represented by an arc or circle within the given tolerance.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public bool IsArc(
	double tolerance
)
Public Function IsArc ( 
	tolerance As Double
) As Boolean

Parameters

tolerance
Type: SystemDouble
Tolerance to use when checking.

Return Value

Type: Boolean
true if the curve can be represented by an arc or a circle within tolerance.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.14
See Also