Curve.TryGetArc Method (Plane, Arc)

CurveTryGetArc Method (Plane, Arc)

Try to convert this curve into an Arc using RhinoMath.ZeroTolerance.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public bool TryGetArc(
	Plane plane,
	out Arc arc
)
Public Function TryGetArc ( 
	plane As Plane,
	<OutAttribute> ByRef arc As Arc
) As Boolean

Parameters

plane
Type: Rhino.GeometryPlane
Plane in which the comparison is performed.
arc
Type: Rhino.GeometryArc
On success, the Arc will be filled in.

Return Value

Type: Boolean
true if the curve could be converted into an arc within the given plane.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.14
See Also