RhinoCommon API
GeometryBase Class |
Provides a common base for most geometric classes. This class is abstract.

Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)

The GeometryBase type exposes the following members.

Name | Description | |
---|---|---|
![]() | GeometryBase |
Protected constructor for internal use.
|

Name | Description | |
---|---|---|
![]() | Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) |
![]() | HasBrepForm |
Returns true if the Brep.TryConvertBrep function will be successful for this object
|
![]() | HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) |
![]() | IsDeformable |
true if object can be accurately modified with "squishy" transformations like
projections, shears, and non-uniform scaling.
|
![]() | IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Overrides CommonObjectIsDocumentControlled.) |
![]() | IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) |
![]() | ObjectType |
Useful for switch statements that need to differentiate between
basic object types like points, curves, surfaces, and so on.
|
![]() | UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) |
![]() | UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use sharable set of information.
(Inherited from CommonObject.) |
![]() | UserStringCount |
Gets the amount of user strings.
|

Name | Description | |
---|---|---|
![]() | ComponentIndex |
If this piece of geometry is a component in something larger, like a BrepEdge
in a Brep, then this function returns the component index.
|
![]() | ConstructConstObject |
Assigns a parent object and a subobject index to this.
(Inherited from CommonObject.) |
![]() | Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) |
![]() | Dispose(Boolean) |
For derived class implementers.
(Inherited from CommonObject.)This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method. In Rhino for Windows, this member is overridden by Dispose(Boolean). |
![]() | Duplicate |
Constructs a deep (full) copy of this object.
|
![]() | DuplicateShallow |
Constructs a light copy of this object. By "light", it is meant that the same
underlying data is used until something is done to attempt to change it. For example,
you could have a shallow copy of a very heavy mesh object and the same underlying
data will be used when doing things like inspecting the number of faces on the mesh.
If you modify the location of one of the mesh vertices, the shallow copy will create
a full duplicate of the underlying mesh data and the shallow copy will become a
deep copy.
|
![]() | EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Inherited from CommonObject.) |
![]() ![]() | GeometryEquals |
Determines if two geometries equal one another, in pure geometrical shape.
This version only compares the geometry itself and does not include any user
data comparisons.
This is a comparison by value: for two identical items it will be true, no matter
where in memory they may be stored.
|
![]() ![]() | GetBoundingBox(Boolean) |
Boundingbox solver. Gets the world axis aligned boundingbox for the geometry.
|
![]() ![]() | GetBoundingBox(Plane) |
Aligned Boundingbox solver. Gets the plane aligned boundingbox.
|
![]() | GetBoundingBox(Transform) |
Aligned Boundingbox solver. Gets the world axis aligned boundingbox for the transformed geometry.
|
![]() | GetBoundingBox(Plane, Box) |
Aligned Boundingbox solver. Gets the plane aligned boundingbox.
|
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | GetUserString |
Gets user string from this geometry.
|
![]() | GetUserStrings |
Gets a copy of all (user key string, user value string) pairs attached to this geometry.
|
![]() | IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) |
![]() | MakeDeformable |
If possible, converts the object into a form that can be accurately modified
with "squishy" transformations like projections, shears, an non-uniform scaling.
|
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | MemoryEstimate |
Computes an estimate of the number of bytes that this object is using in memory.
|
![]() | NonConstOperation |
For derived classes implementers.
(Inherited from CommonObject.)Defines the necessary implementation to free the instance from being const. In Rhino for Windows, this member is overridden by NonConstOperation. |
![]() | OnSwitchToNonConst |
Is called when a non-const operation occurs.
(Overrides CommonObjectOnSwitchToNonConst.) |
![]() | Rotate |
Rotates the object about the specified axis. A positive rotation
angle results in a counter-clockwise rotation about the axis (right hand rule).
|
![]() | Scale |
Scales the object by the specified factor. The scale is centered at the origin.
|
![]() | SetUserString |
Attach a user string (key,value combination) to this geometry.
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |
![]() | Transform |
Transforms the geometry. If the input Transform has a SimilarityType of
OrientationReversing, you may want to consider flipping the transformed
geometry after calling this function when it makes sense. For example,
you may want to call Flip() on a Brep after transforming it.
|
![]() | Translate(Vector3d) | Translates the object along the specified vector. |
![]() | Translate(Double, Double, Double) | Translates the object along the specified vector. |

Rhino for Mac
Supported in: 5.4Rhino for Windows
Supported in: 6.14
Reference

SystemObject
Rhino.RuntimeCommonObject
Rhino.GeometryGeometryBase
Rhino.GeometryAnnotationBase
Rhino.GeometryBrep
Rhino.GeometryBrepLoop
Rhino.GeometryCurve
Rhino.GeometryDetailView
Rhino.GeometryHatch
Rhino.GeometryInstanceDefinitionGeometry
Rhino.GeometryInstanceReferenceGeometry
Rhino.GeometryLight
Rhino.GeometryMesh
Rhino.GeometryMorphControl
Rhino.GeometryPoint
Rhino.GeometryPoint3dGrid
Rhino.GeometryPointCloud
Rhino.GeometrySurface
Rhino.GeometryTextDot
Rhino.RuntimeCommonObject
Rhino.GeometryGeometryBase
Rhino.GeometryAnnotationBase
Rhino.GeometryBrep
Rhino.GeometryBrepLoop
Rhino.GeometryCurve
Rhino.GeometryDetailView
Rhino.GeometryHatch
Rhino.GeometryInstanceDefinitionGeometry
Rhino.GeometryInstanceReferenceGeometry
Rhino.GeometryLight
Rhino.GeometryMesh
Rhino.GeometryMorphControl
Rhino.GeometryPoint
Rhino.GeometryPoint3dGrid
Rhino.GeometryPointCloud
Rhino.GeometrySurface
Rhino.GeometryTextDot