ObjectTable.AddPointCloud Method (IEnumerable(Point3d), ObjectAttributes)

ObjectTableAddPointCloud Method (IEnumerablePoint3d, ObjectAttributes)

Adds a point cloud object to the document.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public Guid AddPointCloud(
	IEnumerable<Point3d> points,
	ObjectAttributes attributes
)
Public Function AddPointCloud ( 
	points As IEnumerable(Of Point3d),
	attributes As ObjectAttributes
) As Guid

Parameters

points
Type: System.Collections.GenericIEnumerablePoint3d
A list, an array or any enumerable set of points.
attributes
Type: Rhino.DocObjectsObjectAttributes
attributes to apply to point cloud.

Return Value

Type: Guid
A unique identifier for the object.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also