RhinoCommon API
ObjectTableReplace Method (Guid, Curve) |
Replaces one object with new curve object.
Namespace: Rhino.DocObjects.Tables
Assembly: RhinoCommon (in RhinoCommon.dll)

public bool Replace( Guid objectId, Curve curve )
Public Function Replace ( objectId As Guid, curve As Curve ) As Boolean
Parameters
- objectId
- Type: SystemGuid
Id of object to be replaced. - curve
- Type: Rhino.GeometryCurve
New curve to be added. A duplicate of the curve is added to the Rhino model.
Return Value
Type: Booleantrue if successful.

Rhino for Mac
Supported in: 5.4Rhino for Windows
Supported in: 6.8