RhinoCommon API
ObjectTableReplace Method (ObjRef, Point3d) |
Replaces one object with new point object.
Namespace: Rhino.DocObjects.Tables
Assembly: RhinoCommon (in RhinoCommon.dll)

public bool Replace( ObjRef objref, Point3d point )
Public Function Replace ( objref As ObjRef, point As Point3d ) As Boolean
Parameters
- objref
- Type: Rhino.DocObjectsObjRef
Reference to old object to be replaced. The object objref.Object() will be deleted. - point
- Type: Rhino.GeometryPoint3d
new point to be added. The point is copied.
Return Value
Type: Booleantrue if successful.

Rhino for Mac
Supported in: 5.4Rhino for Windows
Supported in: 6.8