BrepEdge.SetEdgeCurve Method (Int32, Interval)

BrepEdgeSetEdgeCurve Method (Int32, Interval)

Set 3d curve geometry used by a b-rep edge.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public bool SetEdgeCurve(
	int curve3dIndex,
	Interval subDomain
)
Public Function SetEdgeCurve ( 
	curve3dIndex As Integer,
	subDomain As Interval
) As Boolean

Parameters

curve3dIndex
Type: SystemInt32
index of 3d curve in m_C3[] array
subDomain
Type: Rhino.GeometryInterval

[Missing <param name="subDomain"/> documentation for "M:Rhino.Geometry.BrepEdge.SetEdgeCurve(System.Int32,Rhino.Geometry.Interval)"]

Return Value

Type: Boolean
true if successful
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also