Curve.IsEllipse Method

CurveIsEllipse Method

Test a curve to see if it can be represented by an ellipse within RhinoMath.ZeroTolerance.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public bool IsEllipse()
Public Function IsEllipse As Boolean

Return Value

Type: Boolean
true if the Curve can be represented by an ellipse within tolerance.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also