Curve.IsEllipse Method (Double)

CurveIsEllipse Method (Double)

Test a curve to see if it can be represented by an ellipse within a given tolerance.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public bool IsEllipse(
	double tolerance
)
Public Function IsEllipse ( 
	tolerance As Double
) As Boolean

Parameters

tolerance
Type: SystemDouble
Tolerance to use for checking.

Return Value

Type: Boolean
true if the Curve can be represented by an ellipse within tolerance.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also