GripsDrawEventArgs Class

GripsDrawEventArgs Class

[Missing <summary> documentation for "T:Rhino.DocObjects.Custom.GripsDrawEventArgs"]

Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Rhino.DisplayDrawEventArgs
      Rhino.DocObjects.CustomGripsDrawEventArgs

Namespace:  Rhino.DocObjects.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class GripsDrawEventArgs : DrawEventArgs
Public Class GripsDrawEventArgs
	Inherits DrawEventArgs

The GripsDrawEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyControlPolygonStyle
What kind of line is used to display things like control polygons. 0 = no control polygon, 1 = solid control polygon, 2 = dotted control polygon.
Public propertyDrawDynamicStuff
If true, then draw stuff that does not move when grips are dragged, like the control polygon of the "original" curve.
Public propertyDrawStaticStuff
If true, then draw stuff that moves when grips are dragged, like the curve being bent by a dragged control point.
Public propertyGripColor
Public propertyGripStatusCount
Public propertyLockedGripColor
Public propertySelectedGripColor
Top
Methods
  NameDescription
Public methodDrawControlPolygonLine(Line, GripStatus, GripStatus)
Draws the lines in a control polygons.

This is an helper function.

Public methodDrawControlPolygonLine(Line, Int32, Int32)
Draws the lines in a control polygons.

This is an helper function.

Public methodDrawControlPolygonLine(Point3d, Point3d, Int32, Int32)
Draws the lines in a control polygons.

This is an helper function.

Public methodGripStatus
Public methodRestoreViewportSettings
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also