HistoryRecord Class

HistoryRecord Class

Provides a single bundling of information to be passed to Rhino when setting up history for an object.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsHistoryRecord

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class HistoryRecord : IDisposable
Public Class HistoryRecord
	Implements IDisposable

The HistoryRecord type exposes the following members.

Constructors
  NameDescription
Public methodHistoryRecord
Initializes a new instance of the HistoryRecord class
Top
Properties
  NameDescription
Public propertyCopyOnReplaceObject
When an object is replaced and the old object has a history record with this field set, the history record is copied and attached to the new object. That allows a descendant object to continue the history linkage after it is edited.
Public propertyHandle
Wrapped native C++ pointer to CRhinoHistory instance
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodSetBool
Public methodSetBools
Public methodSetBrep
Public methodSetColor
Public methodSetColors
Public methodSetCurve
Public methodSetDouble
Public methodSetDoubles
Public methodSetGuid
Public methodSetGuids
Public methodSetHistoryVersion
Specifies a non-zero integer that identifies the version of this history record. The virtual ReplayHistory() functions can check this version to avoid replaying history using information created by earlier versions of the command.
Public methodSetInt
Public methodSetInts
Public methodSetMesh
Public methodSetObjRef
Public methodSetPoint3d
Public methodSetPoint3dOnObject
Public methodSetPoint3ds
Public methodSetString
Public methodSetStrings
Public methodSetSurface
Public methodSetTransorm
Public methodSetVector3d
Public methodSetVector3ds
Top
Remarks
To use this object, just pass it to a RhinoDoc.Add() method along with the needed geometry. Do not reuse this class for more than one history addition.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also