MaterialRefCreateParams Class

MaterialRefCreateParams Class

Options passed to MaterialRefs.Create
Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsMaterialRefCreateParams

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MaterialRefCreateParams
Public Class MaterialRefCreateParams

The MaterialRefCreateParams type exposes the following members.

Constructors
  NameDescription
Public methodMaterialRefCreateParams
Initializes a new instance of the MaterialRefCreateParams class
Top
Properties
  NameDescription
Public propertyBackFaceMaterialId
The Id of the Material used to render the back of an object.
Public propertyBackFaceMaterialIndex
The index of the material used to render the back of an object
Public propertyFrontFaceMaterialId
The Id of the Material used to render the front of an object.
Public propertyFrontFaceMaterialIndex
The index of the material used to render the front of an object
Public propertyMaterialSource
Determines if the simple material should come from the object or from it's layer.
Public propertyPlugInId
Identifies a rendering plug-in
Top
Methods
  NameDescription
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also