ModelComponentType Enumeration

ModelComponentType Enumeration

The ON_ModelComponent::Type enum has a value for each explicit component type and two special values, Unset and Mixed. Use an ON_ModelComponentTypeIterator instance to iterate over the ON_ModelComponent::Type values.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum ModelComponentType
Public Enumeration ModelComponentType
Members
  Member nameValueDescription
Unset0No value set.
Image1Embedded image (bitmap) components.
TextureMapping2Texture mapping.
RenderMaterial3Render material.
LinePattern4Line pattern (linetype).
Layer5Layer.
Group6Group.
TextStyle7Text style.
DimStyle8AnnotationDimension style.
RenderLight9Render light.
HatchPattern10Hatch pattern.
InstanceDefinition11Instance definition.
ModelGeometry12Model objects (points, curves, surfaces, ..., annotation, page details, ...), including objects referenced by instance definitions.
HistoryRecord13History record.
Mixed254Multiple component types. Used when a component type filter must include all explicit component types.
Version Information

Rhino for Windows

Supported in: 6.8
See Also