ObjectMaterialSource Enumeration

ObjectMaterialSource Enumeration

Defines enumerated values for the source of material of single objects.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum ObjectMaterialSource
Public Enumeration ObjectMaterialSource
Members
  Member nameValueDescription
MaterialFromLayer0use material assigned to layer.
MaterialFromObject1use material assigned to object.
MaterialFromParent3 for objects with parents, like definition geometry in instance references and faces in polysurfaces, this value indicates the material definition should come from the parent. If the object does not have an obvious "parent", then treat it the same as material_from_layer.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also