FontTable Class

FontTable Class

Font tables store the list of fonts in a Rhino document.
Remarks
The FontTable is now just a wrapper around the DimStyles table.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjects.TablesFontTable

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class FontTable : IEnumerable<Font>, 
	IEnumerable
Public NotInheritable Class FontTable
	Implements IEnumerable(Of Font), IEnumerable

The FontTable type exposes the following members.

Properties
  NameDescription
Public propertyCount
Number of fonts in the table.
Public propertyCurrentIndex
At all times, there is a "current" font. Unless otherwise specified, new dimension objects are assigned to the current font. The current font is never deleted. Returns: Zero based font index of the current font.
Public propertyDocument
Document that owns this table.
Public propertyItem
Gets the font at a position.
Top
Methods
  NameDescription
Public methodCode exampleFindOrCreate(String, Boolean, Boolean)
Get a DimensionStyle with the specified characteristics the settings other than face, bold and italic are copied from the current style
Public methodFindOrCreate(String, Boolean, Boolean, DimensionStyle)
Get a DimensionStyle with the specified characteristics
Public methodGetEnumerator
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also