ViewInfo Class

ViewInfo Class

Represents the name and orientation of a View (and named view).

views can be thought of as cameras.

Inheritance Hierarchy
SystemObject
  Rhino.DocObjectsViewInfo

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ViewInfo : IDisposable
Public Class ViewInfo
	Implements IDisposable

The ViewInfo type exposes the following members.

Constructors
  NameDescription
Public methodViewInfo(UInt32)
Construct the ViewInfo for active viewport of given doc.
Public methodViewInfo(RhinoViewport)
Access to the ViewInfo for given RhinoViewport
Top
Properties
  NameDescription
Public propertyFocalBlurAperture
Gets or sets the Focal blur aperture of the active viewport
Public propertyFocalBlurDistance
Gets or sets the Focal blur distance of the active viewport
Public propertyFocalBlurJitter
Gets or sets the Focal blur jitter of the active viewport
Public propertyFocalBlurMode
Gets or sets the Focal blur mode of the active viewport
Public propertyFocalBlurSampleCount
Gets or sets the Focal blur sample count of the active viewport
Public propertyName
Gets or sets the name of the NamedView.
Public propertyShowWallpaperInGrayScale
True if wallpaper (if any) is to be shown in gray scale in this view.
Public propertyViewport
Gets the viewport, or viewing frustum, associated with this view.
Public propertyWallpaperFilename
Get filename for wallpaper set to this view, if any.
Public propertyWallpaperHidden
True if wallpaper (if any) is to be hidden from this view.
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also