DocumentOpenEventArgs Class

DocumentOpenEventArgs Class

Provides document information for RhinoDoc events.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    RhinoDocumentEventArgs
      RhinoDocumentOpenEventArgs

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class DocumentOpenEventArgs : DocumentEventArgs
Public Class DocumentOpenEventArgs
	Inherits DocumentEventArgs

The DocumentOpenEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyFileName
Name of file being opened.
Public propertyMerge
true if file is being merged into the current document. This occurs during the "Import" command.
Public propertyReference
true if file is opened as a reference file.
Top
Methods
  NameDescription
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also