BrepLoopType Enumeration

BrepLoopType Enumeration

Each brep loop has a defined type, e.g. outer, inner or point on surface.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum BrepLoopType
Public Enumeration BrepLoopType
Members
  Member nameValueDescription
Unknown0 Unknown loop type.
Outer1 2d loop curves form a simple closed curve with a counterclockwise orientation.
Inner2 2d loop curves form a simple closed curve with a clockwise orientation.
Slit3 Always closed - used internally during splitting operations.
CurveOnSurface4 "loop" is a curveonsrf made from a single (open or closed) trim that has type TrimType.CurveOnSurface.
PointOnSurface5 "loop" is a PointOnSurface made from a single trim that has type TrimType.PointOnSurface.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also