NurbsSurfaceKnotList Class

NurbsSurfaceKnotList Class

Provides access to the knot vector of a nurbs surface.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsNurbsSurfaceKnotList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class NurbsSurfaceKnotList : IEnumerable<double>, 
	IEpsilonComparable<NurbsSurfaceKnotList>, IEnumerable
Public NotInheritable Class NurbsSurfaceKnotList
	Implements IEnumerable(Of Double), IEpsilonComparable(Of NurbsSurfaceKnotList), 
	IEnumerable

The NurbsSurfaceKnotList type exposes the following members.

Properties
  NameDescription
Public propertyClampedAtEnd
Determines if a knot vector is clamped.
Public propertyClampedAtStart
Determines if a knot vector is clamped.
Public propertyCount
Gets the total number of knots in this curve.
Public propertyItem
Gets or sets the knot vector value at the given index.
Top
Methods
  NameDescription
Public methodCreatePeriodicKnots
Compute a clamped, uniform, periodic knot vector based on the current degree and control point count. Does not change values of control vertices.
Public methodCreateUniformKnots
Compute a clamped, uniform knot vector based on the current degree and control point count. Does not change values of control vertices.
Public methodEnsurePrivateCopy
If you want to keep a copy of this class around by holding onto it in a variable after a command completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can call this function as many times as you want.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodInsertKnot(Double)
Inserts a knot and update control point locations. Does not change parameterization or locus of curve.
Public methodInsertKnot(Double, Int32)
Inserts a knot and update control point locations. Does not change parameterization or locus of curve.
Public methodKnotMultiplicity
Get knot multiplicity.
Public methodRemoveKnots
Remove knots from the knot vector and adjusts the remaining control points to maintain surface position as closely as possible. The knots from Knots[index0] through Knots[index1 - 1] will be removed.
Public methodRemoveKnotsAt
Remove knots from the surface and adjusts the remaining control points to maintain surface position as closely as possible.
Public methodRemoveMultipleKnots
Remove multiple knots from this surface
Public methodSuperfluousKnot
Computes the knots that are superfluous because they are not used in NURBs evaluation. These make it appear so that the first and last surface spans are different from interior spans.

http://wiki.mcneel.com/developer/onsuperfluousknot

Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also