RhinoCommon API
Cone Structure |
Represents the center plane, radius and height values in a right circular cone.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)

The Cone type exposes the following members.


Name | Description | |
---|---|---|
![]() | ApexPoint | Point at tip of the cone. |
![]() | Axis | Unit vector axis of cone. |
![]() | BasePoint | Center of base circle. |
![]() | Height |
Gets or sets the height of the circular right cone.
|
![]() | IsValid |
true if plane is valid, height is not zero and radius is not zero.
|
![]() | Plane |
Gets or sets the base plane of the cone. The apex of the cone is at the plane's origin.
|
![]() | Radius |
Gets or sets the radius of the cone.
|
![]() ![]() | Unset |
Gets an invalid Cone.
|

Name | Description | |
---|---|---|
![]() | AngleInDegrees |
Computes the angle (in degrees) between the axis and the
side of the cone.
The angle and the height have the same sign.
|
![]() | AngleInRadians |
Computes the angle (in radians) between the axis and the
side of the cone.
The angle and the height have the same sign.
|
![]() | EpsilonEquals |
Check that all values in other are within epsilon of the values in this
|
![]() | Equals | (Inherited from ValueType.) |
![]() | GetHashCode | (Inherited from ValueType.) |
![]() | GetType | (Inherited from Object.) |
![]() | ToBrep |
Gets a Brep representation of the cone with a single
face for the cone, an edge along the cone seam,
and vertices at the base and apex ends of this seam edge.
The optional cap is a single face with one circular edge
starting and ending at the base vertex.
|
![]() | ToNurbsSurface |
Constructs a Nurbs surface representation of this Cone.
This is synonymous with calling NurbsSurface.CreateFromCone().
|
![]() | ToRevSurface |
Constructs a RevSurface representation of this Cone.
This is synonymous with calling RevSurface.CreateFromCone().
|
![]() | ToString | (Inherited from ValueType.) |

Rhino for Mac
Supported in: 5.4Rhino for Windows
Supported in: 6.8