CurveOffsetCornerStyle Enumeration

CurveOffsetCornerStyle Enumeration

Defines enumerated values for all implemented corner styles in curve offsets.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum CurveOffsetCornerStyle
Public Enumeration CurveOffsetCornerStyle
Members
  Member nameValueDescription
None0 The dafault value.
Sharp1 Offsets and extends curves with a straight line until they intersect.
Round2 Offsets and fillets curves with an arc of radius equal to the offset distance.
Smooth3 Offsets and connects curves with a smooth (G1 continuity) curve.
Chamfer4 Offsets and connects curves with a straight line between their endpoints.
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also