Cylinder Structure

Cylinder Structure

Represents the values of a plane, a radius and two heights -on top and beneath- that define a right circular cylinder.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Cylinder : IEpsilonComparable<Cylinder>
<SerializableAttribute>
Public Structure Cylinder
	Implements IEpsilonComparable(Of Cylinder)

The Cylinder type exposes the following members.

Constructors
  NameDescription
Public methodCylinder(Circle)
Constructs a new cylinder with infinite height.
Public methodCode exampleCylinder(Circle, Double)
Constructs a new cylinder with a finite height.
Top
Properties
  NameDescription
Public propertyAxis
Gets the axis direction of the cylinder.
Public propertyBasePlane
Gets or sets the base plane of the cylinder.
Public propertyCenter
Gets the center point of the defining circle.
Public propertyHeight1
Gets or sets the start height of the cylinder. The center of bottom cap is: BasePlane.Origin + Height1 * BasePlane.ZAxis.
Public propertyHeight2
Gets or sets the end height of the cylinder. If the end height equals the start height, the cylinder is presumed to be infinite. The center of top cap is: BasePlane.Origin + Height2 * BasePlane.ZAxis.
Public propertyIsFinite
true if the cylinder is finite (Height0 != Height1) false if the cylinder is infinite.
Public propertyIsValid
Gets a boolean value indicating whether this cylinder is valid.

A valid cylinder is represented by a valid circle and two valid heights.

Public propertyRadius
Gets or sets the radius of the cylinder.
Public propertyTotalHeight
Gets the height of the cylinder. Infinite cylinders have a height of zero, not Double.PositiveInfinity.
Public propertyStatic memberUnset
Gets an invalid Cylinder.
Top
Methods
  NameDescription
Public methodCircleAt
Compute the circle at the given elevation parameter.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodLineAt
Compute the line at the given angle parameter. This line will be degenerate if the cylinder is infite.
Public methodCode exampleToBrep
Constructs a Brep representation of this Cylinder. This is synonymous with calling NurbsSurface.CreateFromCylinder().
Public methodToNurbsSurface
Constructs a Nurbs surface representation of this cylinder. This is synonymous with calling NurbsSurface.CreateFromCylinder().
Public methodToRevSurface
Constructs a RevSurface representation of this Cylinder. This is synonymous with calling RevSurface.CreateFromCylinder().
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also