DistancingMode Enumeration

DistancingMode Enumeration

Defines how offset and similar operations should work.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum DistancingMode
Public Enumeration DistancingMode
Members
  Member nameValueDescription
Undefined0 Nothing is defined. This serves as null.
Linear1 When geometrically possible, offsets with a linear distance.
LinearFromEnd2 When geometrically possible and an opposite side exists, offsets with a linear distance from that side.
Ratio3 When geometrically possible, uses a percentage of respective neighbours to compute offsets.
RatioFromEnd4 When geometrically possible and an opposite side exists, uses a percentage of respective neighbours to compute offsets.
Version Information

Rhino for Windows

Supported in: 6.8
See Also