Ellipse Structure

Ellipse Structure

Represents the values of a plane and the two semiaxes radii in an ellipse.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Ellipse : IEpsilonComparable<Ellipse>
<SerializableAttribute>
Public Structure Ellipse
	Implements IEpsilonComparable(Of Ellipse)

The Ellipse type exposes the following members.

Constructors
  NameDescription
Public methodEllipse(Plane, Double, Double)
Initializes a new ellipse from base plane and both principal radii.
Public methodEllipse(Point3d, Point3d, Point3d)
Initializes a new ellipse from a center point and the two semiaxes intersections.
Top
Properties
  NameDescription
Public propertyIsValid
Returns an indication of the validity of this ellipse.
Public propertyPlane
Gets or sets the base plane of the ellipse.
Public propertyRadius1
Gets or sets the radius of the ellipse along the base plane X semiaxis.
Public propertyRadius2
Gets or sets the radius of the ellipse along the base plane Y semiaxis.
Top
Methods
  NameDescription
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodToNurbsCurve
Constructs a nurbs curve representation of this ellipse.

This is equivalent to calling NurbsCurve.CreateFromEllipse().

Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also